BAB 5

PROSES EDITING

Ada sebagian web designer dalam membuat situs professional tidak
memanfaatkan Adobe Photoshop dalam merancang web, padahal
dengan software tersebut kita akan lebih mudah dan lebih praktis
dibandingkan harus membuat kode html.

Ketika dokumen Adobe Photoshop tersimpan dalam bentuk web
maka secara otomatis akan membuat tag html sendiri sehingga tidak
perlu bersusah payah mengetik kode html. Anda dapat membuktikan
sendiri seperti nampak pada gambar berikut.

<html=

<head:-

<titlexSitus Bisnis</title>

<meta http-equiv="Content-Type" content="text/html; charset=is0-8559-1">
< /head»

<hody bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" mar

<table id="Table 01" width="780" height="891" border="0" cellpadding="0"
“tr-
<td colspan="16">
<img srco="imagessindex 0l.gif" width="730" height="181" alt='
L o s
“tr-
<t
“ing Fro="imadgessindex 02.gif"™ width="21" height="38" alt=""I
<t

5.1. EDITING AWAL

Situs yang telah dibuat, tidak secara otomatis dapat diisi dengan
komponen (baik teks maupun grafik/gambar). Hal ini dikarenakan
kode html masih dalam bentuk gambar <img src> bukan latar
belakang <background>. Apabila kode html masih dalam status
objek gambar maka Anda tidak dapat memasukkan teks maupun
grafik.
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5.1.1. Mengubah Objek menjadi Background

Tidak semua gambar (image) yang pada web yang telah kita buat
diganti. Jika image tersebut berfungsi sebagai tombol, maka Anda
dapat menambahkan menu pull down agar tampilan website lebih
menarik. Anda juga dapat membuat tombol dalam bentuk mouse over,
dan lain sebagainya.

Pada bagian ini, kita akan mencoba membahas tentang teknik
penggantian objek gambar menjadi latar belakang (backgrdound)
agar kita dapat memasukkan beberapa komponen di dalamnya (teks
maupun grafik).

1. Pertama Kkali, bukalah file index.html menggunakan
Macromedia Dreamweaver.

File Edit View Insert Modify Text Commands Sike Window Help

Common - %E&|@@v@.@|.g

indezx, bl

[ Lo cose "-dSpItuD g|Ttl _lﬁ'ﬁb i @ B &

Contact Us

Service Client

Home | About Us Support

s NEW PRODUCT :: Lo BEST PRODUCT ::

PC
Notebook

Monitor

Peripheral

Gambar 5.1.1.1. Membuka dokumen di Macromedia Dreamweaver

2.  Setelah file terbuka, tentukan terlebih dahulu image mana saja
yang akan di jadikan latar belakang dan bagian mana saja yang
akan dijadikan sebagai tombol. Sebagai contoh, klik image di
bagian bawah teks New Product.
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:: NEW PRODUCT :: i: BESTP

<img|
e v

Src |imagesfindex_26.gf |63 ) Al | emply = v|
Link | B e @9 K O
Gambar 5.1.1.2. Memilih objek yang akan dihapus

Pada bagian Properties, tertulis Src = images/index_26.gif hal
itu berarti kita tidak dapat memasukan teks di atas gambar
tersebut karena objek tersebut adalah image, bukan
merupakan background. Tekan Del untuk menghapusnya.

:: NEW PRODUCT :: 2z BE!
|
ne v s | BIESEE Link[
v (L] | §= i= £2 22 Targe

§|_W_[:] Mo i |:| Bg | I
Gambar 5.1.1.3. Objek telah terhapus
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4.  Klik pada Background URL of cell untuk memilih gambar yang
akan dijadikan latar belakang (background). Oleh karena nama
file yang baru saja dihapus adalah index_26.gif maka gunakan
file tersebut sebagai latar belakang.

BEg i& [ Page Properties... ]

Bg D Birdr D |Background URL of cell|

Gambar 5.1.1.3. Menentukan file gambar sebagai background

5. Ketikkan images/index_26.gif pada kolom Bg.

it NEW PRODUCT :: :: BEST PR

Link,

[+ ]

v M) B2
) |

el Mowrap [] Eqg |imagesfindex_26.qif (3

Iy

Target

Gambar 5.1.1.4. Memasukkan nama file untuk background

6. Lakukan hal yang sama pada bagian lain apabila ingin dijadikan
sebagai latar belakang agar kita dapat memasukkan objek
berupa teks, animasi, maupun gambar.
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5.1.2. Memasukkan Objek

Objek yang dimaksud dapat berupa animasi, gambar, maupun teks.
Dalam Macromedia Dreamweaver proses memasukkan objek sangat
mudah karena sudah disediakan tool yang sangat lengkap. Anda
tinggal memilih objek apa yang akan dimasukkan.

Berikut ini akan membahas masalah teknik memasukkan objek
berupa teks.
1. Letakkan kursor pada tempat yang akan ditambahkan teks.

:: NEW PRODUCT ::

PC

MNotebook

Maonitor

Peripheral

Gambar 5.1.2.1 Menempatkan kursor pada area teks

2. Pada penel Properties, aturlah beberapa spesifikasi seperti
nampak pada gambar berikut.

i w Properties

Format |Hone v | Stvle | None v|[cs | B I

Font | Default Font % | Size | None s I__ I:I H
= el Horz |Default | W Mowrap [ Bg |images,|'index_26.gif
I-I-I

1 3B Wert|Top | H Headsr [ | Bg hl:l Brdr

Gambar 5.1.2.2. Panel Properties

"B

il
I
I

3. Ketikkan beberapa kalimat yang berisi berita, kemudian aturlah
format teks tersebut seperti nampak pada gambar berikut.
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4.

:: NEW PRODUCT ::

}{nmputerjenis ini sangat handal digunakan :
untuk berbagai keperluan Tidak semua gambar :
fimage) yang padaweb yang telah kita buat
diganti. Jika image tersebut herfungsi sebagai
tombol, maka Anda dapat menambahkan menu:
pull down agar tampilan website lebih menarik. :
Anda juga dapat menguhah tomboal dalam
bentuk mouse over, dan lain sehagainya

_____________________________________________

Gambar 5.1.2.3. Memasukkan teks pada dokumen

Anda bisa memasukkan image di antara teks tersebut. Untuk
melakukan hal itu, pertama kali letakkan kursor di awal paragraf

kemudian pilih menu Insert > Image.

indez. hkrml*

Tag...

Media

Table
Table Objects
Layaout Ohjects

Farm

Hyperlink,
Email Link.
Marmed Anchaor

Ctrl+E

CErH-AlE+T

Chrl+alE+A

Imﬁ Cbijects *

3

Gambar 5.1.2.4. Memilih menu Insert

Pilih file gambar yang akan dimasukkan dalam dokumen

tersebut.

Select Image Source

Select file name fram: (%) File system
() Data sources

’ Sites and Servers. . ]

Laak. ir: | ) images

910 2 e E-

i ||acer-aspire-3004.ipg *;index_DEu.giF

*:index_lZ.giF

Gambar 5.1.2.5. Menentukan file sumber
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6.

Apabila berhasil memasukkan gambar, maka akan terlihat
objek tersebut berada di depan paragraf. Namun posisinya
masih kurang sempurna karena susunan teks terdorong oleh
gambar tersebut.

:: NEW PRODUCT ::

[ | miomputer jenis ini sangat
handal digunakan untuk herbagai keperluan :
Tidak semua gambar {mage) yang pada web :
¥and telah kita buat diganti. Jika image tersebut
bherfungsi sebagai tombol, maka Anda dapat '
menambahkan menu pull down agar tampilan §
wehsite lebih menarik, Anda juga dapat :
mengubah tombol dalam bentuk mouse over,
dan lain sehagainys

T m A A A e A AT A A AR A AL AR LA AR AL e

Gambar 5.1.2.5. Mengklik objek gambar

Agar tampilan lebih rapi, Anda dapat mengatur posisi gambar
sehingga seluruh teks akan berada di sebelah kanan gambar.
Untuk melakukan hal tersebut, pada panel Properties pilih Left
untuk Align.

- . - Defaulk
div.styleZ = <div.stvled > [<img > Bassling
Top B
Middle
X . Biotkam
Src | sfacer-aspire-3004.ipg 53 1) alk TextTap
Link - [Absolute Middle
n DO Ed Absolute Botkom
Target Border Right
Lowy Src ¥ 1) Align | Default v

Gambar 5.1.2.6. Mengatur alignment untuk objek gambar
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5.2. MEMBUAT LINK DAN NAVIGASI

Menu yang mudah digunakan (user friendly) dapat membantu
pengguna ketika mencari informasi yang dibutuhkan. Sebaiknya
menggunakan tombol menu yang umum, seperti: Home, Product,
Service, dan Contact Us.

Dalam Macromedia Dreamweaver, kita membuat Pop-up Menu, dan
Jumping Menu secara mudah. Anda tidak bersusah payah
menuliskan script yang panjang dalam bahasa Javascript karena
telah disediakan tool yang sangat mudah dan fleksibel.

5.2.1. Membuat Pop-up Menu

Keunggulan software Macromedia Dreamweaver dibandingkan
dengan aplikasi lain yang sejenis adalah adanya tool untuk membuat
menu pop-up Yyang dibuat dengan bahasa Java. Bagi mereka yang
masih awan dengan bahasa Java, tidak perlu bingung karena
disediakan panel Behavior untuk mempermudah dalam pembuatan
menu pop-up.

Sebelum membuat pop-up menu terlebih dulu harus menyiapkan
nama file sebagai link. Sebagai contoh: ketika user memilih menu PC
maka yang akan muncul adalah pilihan nama computer seperti Acer,
HP, BenQ, dan lain sebagainya. Dan ketika user memilih salah satu
opsi (missal: Acer) maka akan terhubung ke file tersebut.

Dengan demikian, Anda harus membuat beberapa file dengan bentuk
interface yang sama seperti halaman utama, yaitu menyimpan
dengan nama lain (contoh: Save As > acer.html). Diasumsikan, Anda
telah memiliki beberapa file sebagai link yang dimaksud.

1. Pertama kali, klik menu PC.

Motebook

Gambar 5.2.1.1. Mengaktifkan salah satu objek gambar
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2.

Jika panel Behaviors belum muncul, aktifkan terlebih dulu
dengan cara memilih menu Window > Behaviors.

Win lj i H EI P

v Insert Chrl4+F2

v Properties Chr+F3
(255 Skyles Shift+F11
Layers F2

Behaviors Shift+F<

Dakabases Crrl+5ShifE+F10

Gambar 5.2.1.2. Mengaktifkan panel Behaviors

Pada panel Behaviors (berada di sebelah kanan), klik tombol
Add (tanda plus) untuk membuka menu

N
£ fpplication

Ji

i w Tag <img::

Behaviors

L

Gambar 5.2.1.3. Membuka menu Behaviors

Selanjutnya pilih Show Pop up Menu.

Popup Message

Preload Images

=et Mav Bar Image

Set Text k
Shaw Pop-Up Menu

Swap Image
Swap Image Restore
Timeline k

Gambar 5.2.1.4. Mengaktifkan menu Show Pop-up Menu

Setelah mengklik pilihan tersebut, maka akan muncul kotak
dialog Show Pop-up Menu yang masih kosong.
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J Contents |.ﬁ.ppearan|:e Advanced Position K

Cancel

Menu: Hl}l Ad
Texk: Target:
Link: | | B

Texk | Link. | Targek
Tlew ikem

Help

Gambar 5.2.1.5. Kotak dialog Show Pop-up Menu

Pada Tab Contents, masukkan nama menu pada kolom Text
(misal: Acer).

‘ Conkents |ﬁ.ppearance advanced Position

Menu: =|='| :]1]
Texk: |-‘:"':'3r | Target:

Gambar 5.2.1.6. Memasukkan judul untuk menu

Kemudian masukkan alamat URL pada kolom Link.

Menu:EIE] =|='| :]1]

Texk: | Bcer

Link: | acer,html

Gambar 5.2.1.7. Menentukan alamat Link

Selanjutnya pada kolom Target, pilih _parent.

Target: v

Gambar 5.2.1.8. Menentukan target

Untuk membuat menu yang baru, Kklik tanda plus (+) di bagian
atas. Kemudian lakukan hal sama seperti pada tahap 6.
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Show Pop-Up Menu

J Contents |.ﬁ.ppearance Advanced Position
e 215 38 B
elp
Text: |BE|'IQ Target:
Lirk.: ||:|enq.html | o
Texk | Link | Targek
Arer acer.hkml _parent
hp hp. bkl _parent

beng. hkml _parent

Gambar 5.2.1.9. Membuat beberapa menu baru

10. Selanjutnya, klik Tab Appearance untuk mengatur warna teks
dan latar belakang pop up menu. Tentukan jenis dan ukuran
font yang digunakan. Lalu tentukan pula warna teks dan warna
cell ketika mouse berada di atas teks.

|\|'erti|:al MEni W |
Font: |\J'er-:|ana, Arial, Helvetica, sans-serif w |
*Size: B| 7| = ==
Up state: Over skake:
Texk: ﬂ Texk: E
Cell: ﬂ Cell: ﬂ

Gambar 5.2.1.10. Mengatur spesifikasi untuk teks menu

11. KIlik Tab Advanced untuk menentukan lebar, tinggi dan warna
border kotak pop up menu.

Cell width: |_| |F'.utn:|matin: v|

Zell height: I_l |F'.ut|:|mati|: v|
Cell padding: Texk indent: III
Cell spacing: EI Menu delay; ms

Pop-Up borders: ] iSth borders:

Barder width; I:I Shadow; E
Border color: D Highlight: D

Gambar 5.2.1.11. Mengatur spesifikasi kotak menu
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12. Klik Tab Position untuk menentukan posisi pop up menu.

Menu posikion: |l. | g ﬁ s

w182 ¥i|0

Hide menu on onMousedut event

Gambar 5.2.1.12. Menentukan posisi pop-up menu

13. Setelah selesai klik OK. Untuk melihat hasilnya, klik tombol
F12.

komput
sangat t
digunak
herbags
Tidak se
(image)
vang tel:
diganti..

PC

Notebook

, mengubah tombol dalam bhentul
Monitor dan lain sebagainya

Gambar 5.2.1.13. Hasil akhir pembuatan pop-up menu

14. Untuk mengasah keterampilan Anda, buatlah pop-up menu
pada tombol lain.
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5.2.2. Membuat Rollover Image

Macromedia Dreamweaver selain menyediakan tool untuk membuat
Pop up Menu juga menyediakan tool untuk membuat Rollover Image
sebagai tombol. Yang harus Anda lakukan pertama kali adalah
menyediakan dua buah gambar yang ukurannya sama tapi warnanya
berbeda.

1. Buatlah duplikasi gambar tombol yang telah ada.

About Us About Us

index_03.gif index_03_over.gif

Gambar 5.2.2.1. Menyiapkan dua buah gambar

2. Kemudian editlah file hasil duplikasi tersebut menggunakan
Adobe Photoshop. Pilih menu Image > Adjustment >
Hue/Saturation.

WA Adobe Photoshop
File Edit BIgEsES Laver Seleck Fiker  Yiew Window  Help

[:] - Mode d Style: | Marmal W
adjusktrments Levels,., ChrHHL
i Auko Levels Shift-+CErl+L
E Duplicate... Auto Contrast  Alt+Shift+Chrl+L
L™
Q )\ Curves, ., ChrHr
‘ Image Size. .. Alk+Chrl+I Color Balance. .. Ckrl+B
ﬁ X «|  Careas Size.., BlE+CEC Brightness/Contrast..,
Jy. & a Pixel Aspect Ratio : Hue/Saturation. .. Chrl+L
2 gy Rorsecames Desaturate S Shitsctrl)

Gambar 5.2.2.2 Memilih menu Hue/Saturation

3.  Setelah muncul kotak dialog Hue/Saturation, aktifkan pilihan
Colorize. Kemudian geser Slider Hue maupun Saturation
sesuai kebutuhan. Setelah selesai klik OK, simpan dokumen
tersebut dengan cara menekan Ctrl+S.
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Hue/Saturation [z|
oy
e
Saturation:
A
Lightriess: EI
o~
et
[¥] Calarize
} j j [¥] Preview

Gambar 5.2.2.3. Kotak dialog Hue/Saturation

Sekarang kembali ke Macromedia Dreamweaver. Klik gambar
About Us.

Gambar 5.2.2.4. Mengaktifkan salah satu objek

Hapuslah objek tersebut dengan cara menekan tombol Del.
Selanjutnya pilih menu Insert > Image Objects > Rollover
Image.

& Macromedia Dreamweaver 8 - [K:\Artikel Datakom\Web Design unt
File Edit Miew BGEEAS Modify Text Commands  Site  Window  Help

Tt Taq... Ckrl+E | @ . :'E;'ﬁ ‘

Image ChrlAlk+1

Image Objects r Image Placeholder
i +
it 7 " IR
i 42| Code | Les Mavigation Ba
Lol code |2 Chrl+AlE+T Firejmks L
b l:: trrlenn E:I:: 1 Table Obiects

Gambar 5.2.2.5. Mengaktifkan menu Rollover Image

Setelah muncul kotak dialog Insert Rollover Image, berilah
nama gambar pada kolom Image name kemudian tentukan
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gambar asli pada kolom Original Image. Untuk mempermudah
pencarian file, klik tombol Browse. Tentukan pula file untuk
gambar rollover pada kolom Rollover Image.

Rollover Image:

Select file name from: (3 File system SieElEee.

() Data sources

Loak in: | £ images v| € ? ® - Image preview

Service e
About Us I

index_04, gif

[

index_03. gif

]

File name: [index_03_over.gi | [ ok 91 % 3BGIF, 3K /1 sec

Filez of type: |Irnage Files [*.gif.” jpg.” jpeg;”.pna) v| Cancel
Gambar 5.2.2.6. Menentukan gambar asli dan gambar rollover

7.  Masukkan teks alternat pada kolom Alt, lalu tentukan nama file
sebagai link ketika tombol tersebut di klik.

alternate text: | about Us

When clicked, Go to URL: | about, html

Gambar 5.2.2.7. Menentukan alternat dan alamat URL

8.  Untuk melihat hasilnya, tekan tombol F12.

Gambar 5.2.2.8. Hasil akhir pembuatan rollover image menu
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